尝试使用斐讯N1在armbian终端下播放音乐

未分类 评论 1 条 2月月 26日, 2019

十年前刚开始玩linux的时候,记得用mocp和mplayer在linux终端下播放音乐和视频装过比,现在突然记起这些东西,想在N1上尝试下。

N1刷的armbian5.67版本,无桌面,纯终端。

先装好了mocp

apt-get install moc

然后 安装和配置linux声卡驱动ALSA 

apt-get install alsa-base alsa-utils 

在配置文件/etc/modprobe.d/alsa-base.conf中添加配置: 
options snd-usb-audio index=0 
注意上述配置需要根据情况配置为0或者其他数字。具体配置的数字为多少需要根据/proc/asound/cards中声卡前面的序号而定。 
另外配置文件/etc/security/limits.conf需要添加: 
@audio – rtprio 99 
@audio – memlock unlimited 
@audio – nice -10

然后尝试启动mocp

报错,提示找不到声卡驱动

输入命令alsamixer查看声卡控制界面,提示“this sound device does not hava any controls”

貌似有问题,这个报错到底是说没有输出设备,还是说声卡驱动的问题我也不清楚,爬了下文,有一些英文文章有介绍,看的头大。

我大概猜了一下,错误原因应该是以下两种 情况之一

第一种就是没有输出设备,由于我手头没有电视机,而N1通过HDMI输出到显示器上是没有声音了,所以没发声设备,解决思路,听说现在大神们已经解决新版的armbian的蓝牙驱动问题,尝试装个蓝牙驱动,用蓝牙音箱输出尝试一下,但是暂时没打算更新系统,以后再尝试。

第二种情况就是N1自带的声卡还是驱动不起来,打算买个usb DAC尝试一下,而且usbDAC应该会有耳机输出孔,想了下觉得这种思路比较靠谱点儿,等有时间再去尝试,懒。。。

2019-3-1更新

买的usb声卡到了,

cat /proc/asound/cards

发现usb声卡可以被正常识别,买的是免驱的,貌似没问题了。

尝试启动mocp,仍然提示没有声卡驱动

然后进入alsamixer看了下,声卡确实可以识别到,又去爬了半天文,改了一堆配置 ,没有作用,又改了/lib/modprobe.d/aliases.conf 这个文件,仍然不行,当然我的系统一直是没有重启的,不知道跟这个有没有关系。

然后找到一条测试声卡的命令

speaker-test -Dplughw:CARD=1 Device -c2 -twav

结果居然可以正常发声,额,离成功近了一步,说明声卡是可以正常工作的。

后来又找到一个文章,说是要给alsa设置配置文件,要指定默认声卡,于是将之前的配置全部还原,新增一个alsa的配置文件

vim /etc/asound.conf

在其中添加一下内容:

defaults.ctl.card 1

defaults.pcm.card 1

defaults.timer.card 1

这里需要注意,card 1是因为我通过cat /proc/asound/cards查到我的usb声卡编号是1。

保存配置然后再次启动mocp,成功

1 条留言  访客:0 条  博主:1 条

评论加载中,请稍等...

发表评论

昵称*

邮箱*

网址